Classes from sub project are not visible to the rest of the webrest sub projects

Am doing some work with the rest module in the sub project, and some how am failing to achieve what i want. I have realised all the clases in the sub project are not visible to the rest of the sub projects , and its what causes me problems. was it intended thatway …or probably its a local problem on my machine.

it seemed to be a local problem in my project setup

@mozzy , so does the problem get solved?

1 Like

ok the import problem gets solved. but i dont understand why i had to manually fix the project set up. let me see if my issues gets fixed now.

it has just gotten worse after fixing the project setup manually

How would like to use these classes @mozzy ?

thanks @ruhanga. but i have solved this. what was cause of my problems was the improper application of versions ie supportedOpenmrsVersions = { “1.10.", "1.11.” }` in the different resources am making changes to. but i have finally solved it. so i had to properly set the right version rightly as per the changes for the right resources. I ddnt know setting the versions improperly could have such serous issues. i thought those versions are only interpreted when the opnmrs instance is running.

1 Like