CI build falling apart

There are 3 CI build falling on the following links kindly help me fix them

Cc @cintiadr

Well, I ‘fixed’, by running the builds with jdk 8 instead of 7. As it’s just for javadocs, it’s not a big deal.

So it’s not clear to me what happened. One theory is that jfrog changed their server configuration, and JDK 7 by default is using a deprecated algorithm.

We ran into a similar problem with our pipelines here at PIH, for what it’s worth, and switched to JDK 8.

Take care, Mark

We had some builds start failing over the last few days. Switching to Java 8 fixed it. I also installed latest OpenJDK 7 JDK ( it had been using oracle jdk7), and switched to that and it also fixed the problem. I stuck with that approach to stay consistent building with a Java 7-based JDK.



Thanks for the effort i was imagining how we are going to have frequent ci build failures on jdk 7.

@mseaton are you able to tell me which update of OpenJDK 7 worked for you?

@cintiadr, our CI server is running Ubuntu 14.04.5 LTS. I just installed the latest version “sudo apt-get install openjdk-7-jdk”.

Checking the version, this appears to be:

java version "1.7.0_181"
OpenJDK Runtime Environment (IcedTea 2.6.14) (7u181-2.6.14-0ubuntu0.1)
OpenJDK 64-Bit Server VM (build 24.181-b01, mixed mode)