Can't startup webapp stuck in maintenance mode

Application Name: Openmrs 2.0 Version Number: 2.0

Question: I built the .war in Java 8 and copied to tomcat webapps Tried in both tomcat-7 and tomcat-8.0.30. At the start it shows the following page.

When I logged in, shows the following.

I have being trying doing everything for nearly fivedays. Your help in this is highly appreciated.

Thanks, @tharaka

What do you have in the logs?

At the startup it gives the error at:

No logs after that.

Try restart tomcat and see what happens.

Still the same comes up.

Can i look at the current log?

At the startup full log is at:

No logs after that.

Close the browser, and then reopen it to access openmrs. Send us a screenshot of the browser page.

Here it is.

Log in with the username and password that you earlier on supplied.

Still the same comes as follows.

Drop the database, delete the runtime properties file and try again.

I did so. Then everything went find until the final step “Update the database”. This error is given in the tomcat. This is shown in the browser.

Which version of the legacyui module are you using?

I built it myself from the master branch. It is 1.0 SNAPSHOT.

Pull the latest module changes and rebuild it again. Am also assuming you are using the latest master or 2.0.x branch. Overwrite the compiled module and try again.

1 Like

@tharaka, if i’m right, you’re working on tickets for an OpenMRS module, right? in that case, you might just want to download the OpenMRS war, instead of building it on your own? if you can install OpenMRS 2.0 alpha, and install just the modules you need atop that, you should be fine, right?

1 Like

@tharaka, any luck with this? I hope that all is well :slight_smile: :slightly_smiling:

I tried with both master and 2.0.x branch. But still no luck. This time it starts good. But when loading legacy UI gives this exception. :frowning: Can you build these two yourself and getinto work. Please let me know the tomcat version, java version and branches of openmrs-core and openmrs-module-legacyui that you are successful with.

No luck with building myself. It gives errors always. Maybe we need to look into this. However going to try your succession.