Can't access home page using Vagrant VirtualBox

I am not able to access OPENMRS or BAHMNI HOME page after setting up via Vagrant Virtual Box. However i am able to smoothly access the links for openELIS and openERP.

Kindly help. Thanks

Getting the ERROR : unable to fetch locations. Please Relaod while accessing

Can you try this : Unable to Fetch Locations Error -- on installing Bahmni


I tried final steps provided as the solution in the link but here i am not able to load the openMRS homepage itself.

I tried ‘setsebool -P httpd_can_network_connect true’ command but it was not getting executed.

I also tried removing openMRS cache folder but was not alble to get the results.

What was the error when you tried to execute setsebool command?

This command is neither getting completed nor showing any error. Is there a specific path for it to execute ?

And also i am not able to open the openMRS page at

That command doesn’t need any specific path. Try setenforce 0. Basically, we are trying to disable SELinux.

Restart OpenMRS service openmrs restart. That should get the OpenMRS service up and running.

Try to restart apache server service httpd restart. If it still shows ‘unable to fetch locations’ check its logs at /var/log/httpd/. Mainly ssl_error_log files for any permission related issues.

[Tue Mar 15 12:52:03 2016] [warn] [client] incomplete redirection target of ‘/bahmni/home/’ for URI ‘/home’ modified to ‘’ [Tue Mar 15 12:53:15 2016] [error] [client] File does not exist: /var/www/html/favicon.ico, referer: [Tue Mar 15 13:04:59 2016] [warn] [client] incomplete redirection target of ‘/bahmni/home/’ for URI ‘/home’ modified to ‘

** These are the ssl_error logs.

[Tue Mar 15 13:46:03 2016] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0 [Tue Mar 15 13:46:03 2016] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec) [Tue Mar 15 13:46:03 2016] [warn] module cache_module is already loaded, skipping [Tue Mar 15 13:46:03 2016] [warn] module disk_cache_module is already loaded, skipping [Tue Mar 15 13:46:03 2016] [warn] module wsgi_module is already loaded, skipping [Tue Mar 15 13:46:03 2016] [notice] Digest: generating secret for digest authentication … [Tue Mar 15 13:46:03 2016] [notice] Digest: done [Tue Mar 15 13:46:03 2016] [notice] Apache/2.2.15 (Unix) DAV/2 mod_wsgi/3.2 Python/2.6.6 mod_ssl/2.2.15 OpenSSL/1.0.1e-fips configured – resuming normal operations

** These are the error logs

Did you try setenforce 0?

yes sir !!

Don’t call me sir! :slight_smile:

The problem is that SELinux is enabled on your virtual machine. Can you please restart the vagrant box and run setsebool -P httpd_can_network_connect true again?

i reloaded vagrant and executed the command but it is not completing . Waiting for the execution to complete.

What was the output of setenforce 0?

while i executed setenforce 0 it just got completed without showing any output. and that setsebool command is executing from last 15 mins but is not giving any output so i had to kill the process.

Check the status using sestatus. If it is enabled then use to disable it. That should solve the problem.

You have to restart httpd service to get the changes effective.

yup… i ll try that right away !!

I tried to change the config file with httpd service restart and was able to disable SeLinux completely. Event the command ‘sestatus’ is showing it disabled. But still i am getting the error (Unable to fetch locations) when i load the Bahmni home page.

Kindly guide me ahead.

Please check whether all OpenMRS modules are running at

Try this one, remove bahmni-web and httpd and reinstall them.

Stop httpd service httpd stop Use yum remove bahmni-web and yum remove httpd to remove. Use yum install bahmni-web. It installs httpd as well.