Cannot login to Android test server

I downloaded the client on my Android phone and attempted to login using admin/Admin123 without luck. Has the username/password changed? Thanks

Can you confirm what server URL you are using to connect? That will help folks to investigate. Thanks!

Sorry for not including the server URL - I’m using the test server, as mentioned on the wiki page: http://devtest04.openmrs.org:8080/openmrs

Thanks! It does seem that the credentials you provided above work on that server. So hopefully someone working on the app can jump in with some ideas. :smile:

The credentials work when I log in from my desktop, but not from my phone… Thanks Michael

@levine, did you pick a location from the dropdown list when trying to log in?

Sure…of course, the login button is not active without selecting a location

@levine, are you able to access http://devtest04.openmrs.org:8080/openmrs from your mobile?

@kkalfas, is there any way to get some application logs from Barry to find the issue?

I have tested the app and it works for me.

@levine First of all if u are using app from Google Store, please update URL by removing last slash. To get logs you must install any app that allow you to explore file structures i.e. Total Commander. Than you should go into sdcard/Android/data/org.openmrs.mobile/files/OpenMRS and you will find there log file named OpenMRS.log.

3 Likes

Great - it works :slight_smile: I’ve successfully logged in and played around a bit.

Thanks much!

1 Like

Hi, I tried your suggestion, I am able to login. However, after logged in, I got a Warning told me “You change url or username. All data will be lost. Are you sure?” If I select “cancel”, I am not able to log in; if I select “ok”, I am not able to find any patients. Any suggestions? Thank you.

Hi,

Can you tell me how did you fix the issue ? I am facing similar problem.

I always get a response with authenticated as false resulting in snackbar displaying error message.

Credentials Username/Password -:- admin/Admin123

Snackbar Error Message: Invalid login or password, please try again.

REST API >> "http://devtest04.openmrs.org:8080/openmrs/ws/rest/v1/session" Request Header:

Authorization: Basic Og==

Or

Authorization: Basic YWRtaW46QWRtaW4xMjM=

Response

{“sessionId”:“FE5B50FEA1A3535BAFC49D589F3F72C3”,“authenticated”:false}

Hello @veeshal,

The test server on devtest04 seems to not be working for a while as seen in ci.openmrs.org. Switch the server address to https://qa-refapp.openmrs.org/openmrs or https://demo.openmrs.org/openmrs.

1 Like

Hi @ykarim250,

I am getting the same error from https://qa-refapp.openmrs.org/openmrs and https://demo.openmrs.org/openmrs servers as well with credentials admin/Admin123.