Cannot install OpenMRS

Reference Application 2.9.0

Hello! I cannot for the life of me get this to install. Im on a Mac OS 10.14.5 and have updated java version 8. I download it, click on the jar file, and this happens. I don’t know if I need to download anything else before running this, but I’ve been trying for a while now. Thanks in advance!

I just get this error message every time:

@gmartin can you please open and see whats the value you have for connection.password ?

Sorry about. Use pastebin to share your error log errors.

@gmartin do you have a mysql instance running when you start your openmrs RA 2.9.0?

Could you use please to post your errors. Sorry tho

1 Like

Hi! Thank you for the reply! I do not believe so. Would that entail me downloading and running it before attempting to install OpenMRS?

My knowledge of coding and such is minimal but I’m trying to learn new things.

Hi @gmartin

Please Make sure to create a db in your local mysql instance with the root user or any user.

Then try redoing the process :crossed_fingers:t6:

HiI Thanks so much for helping, this is what it says: connection.password=test

Hi @ayesh, thanks for the reply! Im sorry, I am a newbie. I’m not exactly sure what that means. Is there an article or something explaining how to do that?

I am now getting this error:

I downloaded Mysql workbench, I don’t know if that has something to do with the new error. I. am sorry for my lack of knowledge in this area. I appreciate everyone’s help. I really want to use Open MRS

@gmartin try restarting the Server. :).

Hi, thanks for the. reply. How do I do that? Sorry im a novice

Hey please check this. Might be Helpful

What supplemental software needs to be installed for me to use OpenMRS?

Now I am getting this:

The end repeated. more of the same but I don’t have pastern pro so I cut it off

You may want to check out OpenMRS SDK too since it is pretty straightforward and will help you install everything doesn’t already exist on your workstation(For ex: MySQL using docker)

Here is a link to the same

@gmartin there are configuration issues in your /moduleApplicationContext.xml leading to the failure to start openmrs

try to follow

1 Like

@gmartin As for the instruction mentioned in OpenMRS Standalone , you dont need any additional software or tools apart from java8 to install openmrs standalone version.

Update : i have managed to recreate the same issue that you are facing by trying to install the standalone application several times. At one point it started failing by giving the same unauthorized error that you are getting and after that it kept on failing with the same error. So As the first thing i restarted my computer and tried installing again and then it worked :rofl:.

1 Like

Hi @gmartin

Try restarting the machine as @dilantha mentioned.Btw if as @reubenv mentioned I think running the OpenMRS SDK is would be ideal as well :slightly_smiling_face:

I tried restarting, I removed all the old files and shut down the computer as well. I have downloaded and attempted to install a fresh download 11 times.

I think I may have. to give up :frowning:

I have no clue how to use terminal so when I copy and paste the things I’m seeing it doesn’t work.

Thanks for the help though! I looked at the SDK page and there is so much on there that I don’t know if I will be able to figure it out.