cannot find symbol

Kind help please!

After making the expected changes on this TRUNK-4231 ticket as reflected on this commit , I run mvn clean install just to ensure everything is fine. I have run into this error cannot find symbol of which I have failed to solved after ensuring I have:

  1. correct spelling.
  2. Right case.
  3. Proper use of acceptable identifier values.
  4. No variable declaration or variable is outside of the scope am referencing to.

Which I believe could be the cause of this error. I kindly request someone to help me on the way forward. I have run out of options this is the error log

Thanks in advance.

Make sure you have pulled the latest changes from master,this class line 18 is the problem but after looking into your commits, line 18 seems to be no there.

I have tried importing it but on my eclipse I get this error

compilation is not on the build path of a java project

which I have tried fixing by following the following steps by all in vain

  1. Right-Clicked on my project
  2. Went to “Properties”
  3. Choose “Project Natures”
  4. Clicked on “Add”
  5. Choose “Java”
  6. Click “Apply and Close”

Then imported import org.openmrs.api.BaseAttributeType; but still getting the same error.

@jwnasambu does your openmrs-core indicate any Red error flags ? and also did you correctly import it on the path ?

It doesn’t show a red error flag I want to believe I imported it correctly.

Is it possible to see some sort of draft pull request with your changes?

Sure! this is the link

@dkayiwa the above is a commit but here is a draft pull request

Fix your import. BaseAttributeType is not in the org.openmrs.api package. It is in org.openmrs.attribute

Thanks so much. Its fixed.