Cannot delete Role

Hey devs, Am working on automating the End to End Test for RefApp 2.x Roles And Privileges.

I tried deleting a role on the qaserver at but that fails with An error has occured message.

I tried that with the demo server too at

And the local instance of the SDK as well at http://localhost:8083/openmrs/adminui/metadata/roles/

Any assistance on how to go about this?! cc: @dkayiwa @kdaud @sharif


Though the delete button is availed on the Manage Roles Page, its more likely that a role can not be deleted via the page. Deletion of a role should be effective when done via System AdministrationAdvanced Administration

@sharif do you have an idea on the subject?

All one can do here is add a role

Roles are defined in Reference Metadata Module which you cannot remove as part of reference application, However, you can delete a new added Role from legacyui admin section which i would reccommend to use that part as your work.

There was a conversation here which is still worth looking into to figure out whether we might need this functionality working again in ReferenceApplication.

As per that conversation, a recommendation was made to have that ticketted but I guess it wasn’t

Yeap, we can go ahead and create that ticket. Feel free to create that ticket @dkayiwa ,Any objection on this case

@sharif why would i have an objection to what i suggested? :slight_smile:

1 Like

Thanks @dkayiwa.

[RA-1978] Deleting a role on the configure metadata module throws an error - OpenMRS Issues @sharif assess it please

1 Like

Thanks @mherman22 ,Have made it ready for work

1 Like