building a git command

hello OPEN MRS community i was trying to build the git command , after this step;

i tried to execute cd openmrs-core mvn clean package and the results were; kindly what could i do to execute successfully? thanks.

do cd openmrs-core ,press enter then do a mvn clean install

@herbert24 thanks …when ran those codes i succeeded from the start but at the end this is what i see;

@janie sorry about that could this link be of help Using Git - Documentation - OpenMRS Wiki

@joshua thanks let me try it out

@janie kindly this is the error you are getting No compiler is provided in this environment. Perhaps you are running on a JRE rather than a JDK? which is caused by your JAVA_HOME environment variable or your Eclipse IDE pointing to a JRE rather than a JDK. To solve this you must set a correct compiler in your environment by either

  1. Running Maven in Eclipse:If you are running Maven from your IDE check that your environment is using a JDK rather than a JRE. To do that follow this steps: Open your Eclipse, click on WindowsPreferencesJavaInstalled JREs (Verify that the checked JRE refers to a JDK : Select the checked JRE and click Edit… and change the path to the JDK home.)

or

  1. On Windows:Go to System propertiesAdvanced system settingsAdvancedenvironment variable and on the System variables section select the JAVA_HOME variable and click on Edit Fill the form with the following Variable name: JAVA_HOME Variable value: ABSOLUTE_PATH_TO_JDK_HOME

@jwnasambu thanks let me try this out

@jwnasambu thanks dia …i have done like you instructed i but am still facing the same challenge

Oh sorry! kindly I will ping you today for a call (Am sorry I will not ask you for your convinient time because am on medication and I will only reach out when reaction is over . Kindly bare with me!)

@janie was the issue sorted out?

@jwnasambu not yet sorted…

Oh sorry! Kindly I only have 15min. Do you mind sharing the meeting link if its okay with you?

its ok dia am here

@jwnasambu am waiting for the link

You can use this link https://meet.google.com/ejp-mzgs-wiv

@jwnasambu good morning… i followed the link you sent sent me : - YouTube. it illustrates the same steps you previous advised me to follow, i followed them but i still get the same error…am wondering what could be wrong…and does this hinder me from proceeding to a ticket?

@janie I had the same error previously but I had to un-install everything concerning Java restart the PC and re download it but this time JDK not JRES and version 8

@kimote thanks am gonad try it out

@kimote have done it but still encountering the same problem