Build failure while deploying module


(CLIFF GITA) #1

@raff @ruhanga @k.joseph Hello all, i am creating a platform module to regenerate the error as at Error Testing Module Created Using OpenMRS SDK but am getting a build failure when i run mvn openmrs-sdk:deploy after setting up the server Capturee


(Rafal Korytkowski) #2

Please first try:

mvn clean install


(CLIFF GITA) #3

@raff i get the build success after running mvn clean install and when i run mvn clean install openmrs-sdk:run -DserverId=your_server_id i get this Capture4


(Rafal Korytkowski) #4

Paste the full log into pastebin instead of attaching a screenshot. Did you setup a server prior to that?


(CLIFF GITA) #5

@raff am sorry for responding late ,kindly review here https://pastebin.com/tqRmPW9c


(Nathan Ruhanga) #6

Sometimes it can be messy resolving an error that’s resulted from running a stream of commands at once. Can you try breaking your use case into manage-able chunks? Like @raff mentioned, you may want to achieve this step-wise.

  • Create a server (platform/referenceapplication) instance and load a user interface in the case of platform. mvn openmrs-sdk:setup

  • Create the module mvn openmrs-sdk:create-project

  • Deploy the module mvn openmrs-sdk:deploy

The issue I think you are trying to resolve, is realized at the second bullet. The order of the first two doesn’t matter though.


(CLIFF GITA) #7

Thanks @ruhanga :+1: