BUILD FAILURE of openMRS coreapps

hello folks

I’ve been trying to execute mvn clean install but for some reason have been getting omod build failures. i change the node version to v6.10.0 are required but still get then same error. you can find my logs here

please if there is any suggestion on how to solve this, it will be super helpful

cc. @dkayiwa @ibacher @ruhanga

I have just run it successfully with node version v18.17.0 and npm version 9.6.7

oh okay let me try with that suggestion

hello @dkayiwa i am still getting the same error.

Can you share the full error log of what you are now getting?

okay please, let me reproduce the error

hello @dkayiwa please find my full error log here

I mean the full log when you run mvn clean install

hello @dkayiwa sorry for the delay, here is the full log

Delete the node_modules folder under coreapps and then compile again.

still getting the same error

hello @dkayiwa also did a npm run test to see more details, find the error log here

@josephbate Do you have Firefox installed?

yes i do @ibacher

Tell me what happens after doing the following:

  1. Delete the entire coreapps folder
  2. Clone it afresh
  3. Then run mvn clean install

nothing’s changed, still getting the same error :man_facepalming:t5:

@josephbate the version of node and npm you are running are not as above. In the logs, I see;

[INFO] npm ERR! argv "/home/ssegujja/coreapps/node/node" "/home/ssegujja/coreapps/node/node_modules/npm/bin/npm-cli.js" "run" "test"
[INFO] npm ERR! node v6.10.0
[INFO] npm ERR! npm  v3.10.10

i tried all these versions but still get the same error

@josephbate did you do the above?

Could you run the following commands in a new terminal and share the output/logs?

git clean -fdx .
ls -al
mvn clean install
1 Like

yes i delect the node_modules and compiled again this had the same errors

hello @ruhanga the failures have persisted even with what you have proposed