bug in module loading in Openmrs 1.12.1

Steps to reproduce:

  1. Drop a new module that has never been loaded in your instance of OpenMRS into the modules directory. Make sure the omod has an error that would prevent it from starting

  2. Start Openmrs

  3. Check the Openmrs module admin page. You will notice that the module is not in the list and there are no errors related to the module. Also, there are no global properties related to the module.

  4. Try to load the module again through the webapp as a new module. It shows an error that the module already exists

  5. Try to load the module again through the webapp as an upgrade. Now you finally see the module error

This is a bug. It should display the error in Step #3.

I don’t think I have a jira login (or don’t remember my password) and don’t feel like making one (or changing the password) so someone else will need to open the ticket



I have just tried this on version 1.12.1-SNAPSHOT of OpenMRS by dropping the legacyui module into the modules folder and then started OpenMRS. The module failed to start as expected and when i go to the Manage Modules page, i see the expected error message explaining why it failed to start.

Could it be that it depends on the kind of error? Or could you share the module that failed to start?

I haven’t tried this out, but I don’t think legacyui is the best module to test with in 1.12.1 given that the legacyuui was moved out in a later version i.e. 2.0

Tammy said a module that would not start. So i used legacyui because i was sure it would not start. :slight_smile:

I get that, but the fact that some of the steps she described involved navigating through the legacyui, then I smell a whole lot of mess to even do so given that you have 2 UIs duplicating each other.

There is no mess because the legacyui module should not even start at all.