Blank Report administration page

Hello Guys, i am trying to follow how the reporting works while i implement but when i click the link on the link** Report Administration** under Manage Report Definitions i get a blank page, i really donot know what that means and if i have gotten it all wrong please i need help with this ASAP. the picture below shows the screen shot

thank you guys for the encouragement and support given me and i wish you guys are always there regards,

Can you View Source of this page and see if there is an embedded error? (Or else look at your server log and see if there is one there?)

It looks like the page was interrupted.

thanks @darius i will do that and get back if i found something

I’m getting a similar error with a complete blank page and no error in the source to display. With this error in the server log:

This I’ve tried with both 0.9.4 version and version of reporting module. I assumed it to be an issue with a specific build as it has org.openmrs.module.reporting.web.taglib does not exist error. But it has the same error for both the versions. I’m running 1.11.4 version of OpenMRS

Can you give some more information about your running environment? Like what version of Java? Are you running from IDE, standalone? Have you just installed/started/stopped modules via the browser? What other modules are you running? Does a restart of tomcat/jetty fix it? Or anything else that you fill may be helpful.

I’m running it in jetty debugging environment using intellij, java version : 8, I have reference application 2.2 setup. Initially installed the modules by directly placing them in the folder, starting/updating and stopping using browser. Restart of jetty does not help.

Does it still happen if you use the latest reference application?

I am not using the latest reference application.Will try to update and check.

But, why does it have to depend on the version of reference application, shouldn’t it depend on the version of platform and reporting module.

The first thing I would check would be whether it is an issue running Java 8. Does the issue persist with Java 7?

Turns out, the issue was with the version of jetty I was using ( I was using jetty 8 because of a ticket earlier). The stock version OpenMRS core works fine. Sorry for the inconvenience :grin:

1 Like