Bahmni virtualbox problem


I’m trying to run the bahmni v 0.86 in virtual box but its giving me a timeout error. i’m using windows 10 version 1607 (os build is 14393.576). VirtualBox version is 5.1.12r112440(Qt5.6.2). vagrant 1.9.1

when i do vagrant up i get following error: Bringing machine ‘default’ up with ‘virtualbox’ provider… ==> default: Clearing any previously set forwarded ports… ==> default: Clearing any previously set network interfaces… ==> default: Preparing network interfaces based on configuration… default: Adapter 1: nat default: Adapter 2: hostonly ==> default: Forwarding ports… default: 22 (guest) => 2222 (host) (adapter 1) ==> default: Running ‘pre-boot’ VM customizations… ==> default: Booting VM… ==> default: Waiting for machine to boot. This may take a few minutes… default: SSH address: default: SSH username: vagrant default: SSH auth method: private key The guest machine entered an invalid state while waiting for it to boot. Valid states are ‘starting, running’. The machine is in the ‘unknown’ state. Please verify everything is configured properly and try again.

If the provider you’re using has a GUI that comes with it, it is often helpful to open that and watch the machine, since the GUI often has more helpful error messages than Vagrant can retrieve. For example, if you’re using VirtualBox, run vagrant up while the VirtualBox GUI is open.

The primary issue for this error is that the provider you’re using is not properly configured. This is very rarely a Vagrant issue.

my vagrantfile content is :

-- mode: ruby --

vi: set ft=ruby :

Vagrant.configure(2) do |config| = “my-bahmni-box” config.vm.box_url = “file:///c:/Project/bahmni/bahmni-vagrant/” config.vm.box_check_update = true config.ssh.insert_key = false “private_network”, ip: “”

config.vm.synced_folder “…”, “/bahmni”, :owner => “vagrant” config.vm.provider “virtualbox” do |v| v.customize [“modifyvm”, :id, “–memory”, 3092, “–cpus”, 2, “–name”, “Bahmni-RPM”] end end

when i check the VirtualBox Manager it shows Bahmini-RPM is running

i tried vagrant ssh and the output of this command is : ssh executable not found in any directories in the %PATH% variable. Is an SSH client installed? Try installing Cygwin, MinGW or Git, all of which contain an SSH client. Or use your favorite SSH client with the following authentication information shown below:

Host: Port: 2222 Username: vagrant Private key: C:/Users/Babi/.vagrant.d/insecure_private_key

update: i installed openssh and tried to connect but there also the error is same connection timedout

Please help

Dheeraj Jadhav

Can you see if the below link helps.

Hi Swathi,

I tried all the links which your link points to but the problem remains. i can see the virtualbox starting in the preview and it waits at the “Give root password for maintenance prompt”

it also shows while checking the file systems it contains error and it also finds the Inodes that were part of a corrupted orphan linked list and it finds them.

the error is

/dev/mapper/VolGroup-lv_root: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY. [FAILED] *** An error occurred during the file system check. *** Droping you to a shell; the system will reboot *** when you leave the shell. Give root password for maintenance (or type Control-D to continue):

what could be wrong ?

one more thing how much ram the system actually needs, both Host and VM ?

Thanks in Advance Dheeraj

Hi @djking,

The VM itself needs 3GB of RAM. How much RAM does your system have? How much of it is free?

Hi @ajjaswanth ,

I’ve got 4GB of RAM and i had allocated 2 gb for the vm.

Hi @ajjaswanth ,

even after increasing the RAM i’m still getting the same error

how do i solve this issue ?

thanks Dheeraj

Hi @djking,

This issue looks specific to VirtualBox. We will not be of much help here. Please check with VirutalBox forums for any specific issues related to the version you are using on Windows 10.

Try doing vagrant destroy and vagrant reload.