Bahmni Services

Hello Community

Apart from below services, what other services need to be running for Bahmni

# service --status-all
atomfeed-console is running with pid: 6304
Service bahmni-erp-connect is running with pid: 18221
Service bahmni-reports is running with pid: 6306
Checking jexec statusnetconsole module not loaded
Configured devices:
lo ens192
Currently active devices:
lo ens192
Service openmrs is running with pid: 6328

Everything was working perfectly until I tried installing Open ERP with below command.

bahmni -i custom --only bahmni-erp install

It was not installed initially when I ran the installer.

The homepage is not even loading

It’s hard to guess without seeing the output of that command, that you state :

So my advice that you put the output of this command:

either a screenshoot or copy paste the whole output

Thanks for your response @eddyprasetyo, I have pasted part of the bahmni-installer log at this paste it

try installing psycopg2-binary via pip

sudo pip install psycopg2-binary

And then re-run the instalation. Hope thats help.

But it’s already installed

# yum list installed | grep psycopg2
python2-psycopg2.x86_64               2.8.3-3.rhel7                   @pgdg10

Hi,

Could you please list what is the output of below command in your server.

yum list installed | grep postgres

I did face this issue when a psycopg2 dependency is not resolved by yum. You should have postgresql10-libs or higher libs version installed. Sometimes dependencies get properly resolved and expected version of libs is installed - sometimes postgresql96-libs are only installed and postgres user module fails

Those were different package. Have you installed psycopg2-binary?

psycopg2 python module should be installed as a pre-requesite by the playbook itself. No need to install it separately.

# yum list installed | grep postgres
Repodata is over 2 weeks old. Install yum-cron? Or run: yum makecache fast
postgresql12-libs.x86_64              12.0-1PGDG.rhel7                @pgdg12
postgresql96.x86_64                   9.6.15-1PGDG.rhel7              @pgdg96
postgresql96-contrib.x86_64           9.6.15-1PGDG.rhel7              @pgdg96
postgresql96-libs.x86_64              9.6.15-1PGDG.rhel7              @pgdg96
postgresql96-server.x86_64            9.6.15-1PGDG.rhel7              @pgdg96

Hi,

I could see postgres12-libs are installed. So, this is not an issue. I would like get more logs to debug the issue further. Could you run

ansible-playbook -i /etc/bahmni-installer/custom all.yml -vvvv --extra-vars '@/etc/bahmni-installer/rpm_versions.yml' --extra-vars '@/etc/bahmni-backrest.conf' --extra-vars '@/etc/bahmni-installer/setup.yml' -t bahmni-erp

This is actually the ansible command that runs when you run

bahmni -i custom --only bahmni-erp install

I just increased log level by adding -vvvv

It gives an error

ERROR! the playbook: all.yml could not be found

A search for the file returns this location

# find / | grep all.yml
/opt/bahmni-installer/bahmni-playbooks/all.yml

Yes, My bad please change the file name to include absolute path.

ansible-playbook -i /etc/bahmni-installer/custom /opt/bahmni-installer/bahmni-playbooks/all.yml -vvvv --extra-vars '@/etc/bahmni-installer/rpm_versions.yml' --extra-vars '@/etc/bahmni-backrest.conf' --extra-vars '@/etc/bahmni-installer/setup.yml' -t bahmni-erp

The same error still appears. I have attached the log filebahmni-installer.txt (595.3 KB)

Hello @bhiravabhatla, any pointers? I’ve been stuck here since last week

Have you tried this?

Another issue with ansible_python_interpretter , with different approach

Thanks @eddyprasetyo

Where do I set inventory variable as suggested below

I found that when I use /usr/local/bin/python I can import psycopg2 but not when using /usr/bin/python . Solved this by setting an inventory variable ansible_python_interpreter: /usr/local/bin/python Both pythons are 2.7

In the inventory file, or in your case in /etc/bahmni-installer/custom

I finally managed to install bahmni- erp. But I still don’t know why I can’t access bahmni from my browser. All services are running

# service --status-all
atomfeed-console is running with pid: 6304
Service bahmni-erp-connect is running with pid: 18221
Service bahmni-reports is running with pid: 6306
Checking jexec statusnetconsole module not loaded
Configured devices:
lo ens192
Currently active devices:
lo ens192
mkdir: cannot create directory ‘odoo’: File exists
odoo-server is running...
Service openmrs is running with pid: 21017

What do you get when you try to access the https://[server]/home?

  • check the network tab in chrome devtools, console etc
  • check the log in /var/log/openmrs/openmrs.log (remember, we have a rotating log, so chances are that the error might be in other files. but starting with openmrs.log is good)