Bahmni Reporting and Date Formats

What is the proper date format with using the Bahmni Reporting feature? I have tried various common Date formats and continue to receive the following error.

Have any thought been given to using a datepicker control or at least adding the expected format at the top?

Thanks for your thoughts.

@dnelson: There seems to be some issue with your installation of Bahmni. The reporting page has a date-time control for selecting dates. See the screenshot below that I took from the Bahmni demo online server:

I am not sure of why that might be happening in your case. Maybe someone else from the team will reply to this thread by tomorrow. Today is Sunday, so most people are offline.

Are you using chrome browser ?

As sravanthi points out, i have seen the date picker and all not working in Safari (and probably other browsers as well). Try using chrome browser, and you should be all fine.

Thank you all for your responses. I am running it on Firefox and there are no datepickers. I have attempted to install Chrome and Chromium onto my CentOS 6.8 server however, it seems they are not supported on CentOS any longer?

Does anyone have special instuctions to install Chromium? I think @sravanthi17 tried to help me in the past with installation but it was also unsuccessful.

Other thoughts / ideas would be appreciated.

I was able to connect to the server with another computer on the network with Chrome and thankfully able to see the dropdowns. So it would be nice to have the ability on the server too but at least they will be able to access it with a windows computer. Still interested if anyone has thought on how to get it from the server directly if possible. Thank you!

Previously we followed this document , where the rpm mentioned in the document is no more available. Any one tried installing chromium recently on centos 6? Please help @dnelson with the installation steps.

This link seems to be the one mentioning how to install Google Chrome on CentosV6.x:

BUT I WOULD SUGGEST THAT YOU NOT INSTALL THIS if you can avoid, because it asks you to do a yum update first – which might cause other issues. If you can currently live with not running reports feature on Chrome CentOS, then i’d let it be for now. Might not be worth the trouble for you.

Moving forward we are going to add support for CentOS v7. I hope meanwhile you can continue with Firefox on your centos instance, and Windows/Chrome on connected machines.

Which version of Firefox are you using?

FirefoxESR 45.7.0