Bahmni Offline Sync: Build fails to fetch dependencies


I am unable to build the bahmni-offline-sync module on master

I suspect the dependencies repos are not public (?):

[WARNING] s3:// - Connection refused
[INFO] Logged off -

Full log:

Any idea?

Bahmni S3 repo is public. But I have faced this before. Usually retrying sometime later works. (I had the impression that S3 goes awry when we are pushing new builds)

Thanks. I have retried today and still no luck. Same error. Maybe the dependency is simply not available on the repo?

@mksrom I tried running it in my local and it builds. Can you try again and let us know? Are you trying on the latest code?

I am trying on the tip of master.

However, it does build if you have the 0.91-SNAPSHOT built previously because it available in your .m2/ (thanks @mksd for this)

Could you try to remove this artifact and try again?

rm -R .m2/repository/org/bahmni/module/

But I can see the artifact in the s3 repo:

Even I can see the artifact in the s3 repo. We will work on the issue. For time being please change

s3:// to

in pom.xml.


Thank you @binduak I can confirm this works.

Just did a PR for this: PR#2

[EDIT] Sorry I haven’t noticed you said it is temporary solution only. Please forget about the PR then…