Bahmni installer seems stuck for a long time on bahmni-erp

I was following the steps mentioned on Bahmni Wiki for installing v0.82 on Centos and it seems my installation got stuck in this line:

TASK [bahmni-erp : Install bahmni-erp from bahmni-repo] ************************ task path: /opt/bahmni-installer/bahmni-playbooks/roles/bahmni-erp/tasks/main.yml:30

Nothing has happened in 15 minutes after that. Should I clean the server and start again or what would be the best way to try again, to continue from here?

(Posted on behalf of a community member)

I also had the same issue when I was installing v0.82 on DO yesterday. It continues after a while. But, if you killed it, or your connection broke, you can login again and just fire “bahmni install” command again. The command has been designed to continue from where it left off, so even if you run it multiple times, it won’t cause any issues.


After this issue, I ran the bahmni instalI script again and got the installation through. Although now it stays running “loading icon” when connecting to [IP address]/home

Where to investigate why I can’t get pass the loading?

Please check the logs “/var/log/openmrs/openmrs.log

Due to a work trip I could go back to the server logs only now. It seems that there are issues concerning running Java (getting exhausted).

Besides that I looked that the other services and databases are running except “Service openmrs is not running, neither bahmni-erp-connect”. Also reports were not running but that went on by the command “sudo service bahmni-reports start”. The similar command didn’t launch openmrs or erp-connect.

We need more information to help you out solve the issue

  1. Centos version
  2. Memory available

OS:CentOS release 6.7 (Final) uname:Linux 2.6.32-573.8.1.el6.x86_64

model name : Intel® Xeon® CPU E5-2650L v3 @ 1.80GHz cpu MHz : 1799.998 cache size : 30720 KB

Environment Variables: JAVA_HOME=/usr/java/jre1.7.0_79 PATH=/sbin:/usr/sbin:/bin:/usr/bin SHELL=/bin/bash

From the Java error log:

Out of Memory Error (os_linux.cpp:2756), pid=3916, tid=140009098286848

JRE version: (7.0_79-b15) (build ) Java VM: Java HotSpot™ 64-Bit Server VM (24.79-b02 mixed mode linux-amd64 compressed oops)

With the command “free” from the server, about the free memory:

         total       used       free     shared    buffers     cached

Mem: 2054300 1941136 113164 38616 13676 156272 -/+ buffers/cache: 1771188 283112 Swap: 2044 2044 0

I added more CPU and RAM and got into the main dashboard now! It’s still quite a slow but atleast doesn’t look like a broken system now.

It redirects all the time to https, instead of the http that is in the Bahmni guidebook (“Step 3: Access the Application”). And that gives constant errors / complains by the different browsers I tested (FF, Chrome).

Like this: https://my-ip-address/bahmni/home/index.html#/dashboard

Hello @generare,

The System Requirements mentioned here expect RAM to be atleast 8GB.

If the RAM is less, the system will run slow, and exit / crash unexpectedly when it encounters a need for storing a larger dataset in memory. Request you to please allocate minimum 8GB RAM.

I think you are using Digital Ocean. It doesn’t come pre-setup with swap space, which acts as a temporary storage of in-memory data on the Hard disk. If you haven’t setup swap space, please read these instructions, to setup atleast 4GB RAM.

This should ensure your Bahmni runs fast.

With regards to HTTP going to HTTPs, it is the desired behaviour. Bahmni EMR runs on HTTPs, which is more secure that HTTP. Apache under-the-hood, will always redirect any http request to https, so that all communication over the wire is encrypted. Bahmni is currently shipped with default certificates, which point to domain:

Since, you are accessing it over an IP Address, the browser complains that certificates do not match the domain being accessed. Hence you see this error/warning about invalid certificates in browser. If you select “Ignore” / “Continue” (Trust these certificates), then next time you won’t see this warning in the same browser.

Ideally, one should setup proper certificates for each deployment. You can do that once you have played with Bahmni. Meanwhile you can just ignore the error and continue. Please read this to understand how to obtain free SSL certificates for your setup:

Alternatively, you can make an entry in your machine, to point to the Digital Ocean IP being accessed, so that in browser when you enter “”, it goes and accesses the right IP address. For that, you will need to update you /etc/hosts file, and make a DNS entry for Its really quite simple, just needs a single entry in your /etc/hosts file: (Shows Windows example too)

I hope this helps.

1 Like

Thanks a lot! I will read this carefully. Well explained! (I’ll make another post about installing the appointment module)

I have had several issues with the installation -

  1. Hung starting mysql service (though it was up, could not read pid, so I removed it from the tasks and went ahead)
  2. Service to save Ip tables - “The service command supports only basic LSB actions (start, stop, restart, try-restart, reload, force-reload, status). For other actions, please try to use systemctl.” for this I followed the steps given here - and moved ahead.
  3. Now I am getting this - “fatal: [localhost]: FAILED! => {“changed”: true, “failed”: true, “msg”: “\n\nTransaction check error:\n file /opt/openmrs from install of bahmni-emr-0:0.82-287.noarch conflicts with file from package bahmni-openmrs-0:0.82-26.noarch\n file /opt/openmrs/etc from install of bahmni-emr-0:0.82-287.noarch conflicts with file from package bahmni-openmrs-0:0.82-26.noarch\n\nError Summary\n-------------\n\n”, “rc”: 1, “results”: [“Loaded plugins: fastestmirror, langpacks\nLoading mirror speeds from cached hostfile\n * base:\n * epel:\n * extras:\n * updates:\nResolving Dependencies\n–> Running transaction check\n—> Package bahmni-emr.noarch 0:0.82-287 will be installed\n–> Finished Dependency Resolution\n\nDependencies Resolved\n\n================================================================================\n Package Arch Version Repository Size\n================================================================================\nInstalling:\n bahmni-emr noarch 0.82-287 bahmni 41 M\n\nTransaction Summary\n================================================================================\nInstall 1 Package\n\nTotal size: 41 M\nInstalled size: 42 M\nDownloading packages:\nRunning transaction check\nRunning transaction test\n”]}”

This is my first experience with centos - so I am struggling - uname -a - … 3.10.0-327.22.2.el7.x86_64 #1 SMP Thu Jun 23 17:05:11 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Thanks for any help, Ashok

Which version of Centos are you using?

cat /etc/redhat-issue

Can you also check the RAM, and HDD size and let us know.

When you installed CentOS, which flavor did you use? (Minimal, Desktop Edition, etc)?

$ free total used free shared buff/cache available Mem: 7967140 860244 5536836 9168 1570060 6842744 Swap: 8257532 0 8257532 $ rpm --query centos-release centos-release-7-2.1511.el7.centos.2.10.x86_64

$ df -H Filesystem Size Used Avail Use% Mounted on /dev/mapper/centos-root 54G 14G 40G 26% / devtmpfs 4.1G 0 4.1G 0% /dev tmpfs 4.1G 87k 4.1G 1% /dev/shm tmpfs 4.1G 9.3M 4.1G 1% /run tmpfs 4.1G 0 4.1G 0% /sys/fs/cgroup /dev/sda1 518M 224M 295M 44% /boot /dev/mapper/centos-home 938G 4.0G 934G 1% /home

I used the instructions here -

but guess I missed this - “CentOS v7 is currently not certified for Bahmni. Please refer to this Mingle card. Request you to please choose CentOS v6.7 for running Bahmni.” ? Thanks for your quick response, Best, Ashok

Try the following steps yum install yum-utils yum-complete-transaction

After running above commands successfully, rerun bahmni install

Many folks have had problems using Centos V7, which is why that issue has been raised. Would request you to instead use Centos v6.7 or 6.8.

Sravanthi’s suggestion came back with same error. I guess I will go with Gurpreet’s and move to Centos v6.7 or 6.8.

Thank you all, Best,


please Any one Help me I am struggle 2 day that Eror but unable resolve that Error. please help why that Error will be occured i am uanble to understand every step I followed via wiki