bahmni installation critical error

even after os update i get this error .

TASK [bahmni-lab : Backup openelis markers, failed_events tables] 
task path: 
 [localhost -> localhost]: FAILED! => {“changed”: true, “failed”: 
true, “rc”: 1, “stderr”: “+ . /etc/bahmni-installer/bahmni.conf\n++ 
OPENMRS_DB_PASSWORD=password\n++ OPENMRS_DB_SERVER=localhost\n++ 
OPENERP_DB_PASSWORD=password\n++ OPENERP_DB_SERVER=localhost\n++ 
REPORTS_DB_SERVER=localhost\n++ REPORTS_DB_PASSWORD=password\n++ 
REPORTS_DB_USERNAME=reports-user\n++ date +%Y%m%d_%H%M%S\n+ 
TIME=20180327_145313\n+ pg_dump -U clinlims -a -t markers -t 
failed_events clinlims\npg_dump: server version: 9.2.24; pg_dump 
version: 8.4.20\npg_dump: aborting because of server version 
mismatch\n”, “stdout”: “”, “stdout_lines”: []}
to retry, use: --limit @/opt/bahmni-installer/bahmni-playbooks/all.retry

. please any help to rectify this. i followed the centos setup process for bahmni line by line.

please anyone encountered issues idfollowe your guidlines

@tmlewin please share some more helpful information:

  • what instructions are you following? (give a link to a wiki page for example)
  • what line of the instructions were you on when this happened?

i fixed it by setting up fresh centos 6.6. i downgraded. and everything installed smoothly. here is the catch though. the appointment modules is missing. no dcm4chee service was installed. in the old setup of version 0.88. in the setup.yml , we add options of enableing dcm4chee and pacs services. the setup.yml in v0.90 seems bare. now after the installation the normal demo data with preconfigured openemrs concepts etc is missing. when i register a patient, there are no options to takes his vitals. evn when i click on condultation. the observation form is empty. no usual vitals plus other forms. is there a demo database that has these data.Please i dont mind showing u my setup so you can understand whats going on.

also when i load the dashboard, i get cannot read property of set members. it seems demo datbase didnt load. many forms and options are missing. i am shocked because installation was 100% sucessful

@tmlewin Build the search indexes: OpenMRS -> Navigate to Administration → Search Index and Run Rebuild Search Index.

fanatstic its fixed.please one last challenge is that there is no appointment module. i see registration ,clinicals,implementer interface e.t.c. are available but appointment module is missing.i dont know why.Thanks

That might be to do with roles/permissions - have a look here to see how to assign user roles for Appointment Scheduling. worked.Thanks. I am currently using centos 6.6 and itseemed to be the only version that worked for centos version 6.9 installation broke down when i used the bahmni install command .but am glad 6.6 works smoothly now

I don’t think the issue was CentOS 6.9. -See the following line in the log you posted:

server version: 9.2.24; pg_dump version: 8.4.20\npg_dump: aborting because of server version mismatch

@govindsharma was having the same issue (…see this post)

You could have fixed it by creating a symlink to psql-9.2 and doing bahmni install again.

sudo ln -s /usr/pgsql-9.2/bin/pg_dump /usr/bin/pg_dump --force

I’m glad you got it working on CentOS 6.6 but still CentOS 6.9 is the recommended version :grinning:

I am installed CentOS 6.9 installed bahmni but unable to open bahmni clinical service getting Error

The Request Information does not exits

open openmrs unable to show user interface

@govindsharma You were given an answer here. Have you tried it?

i have installed bahmni Again

bahmni -i local install

then after same issue how to resolve this problem

please suggest me

Without getting more information or logs, its impossible to say anything Govind! Its evident from your other post, that the modules (OMODs) were not installed. We haven’t seen this case (ever) before and without the installations logs - its impossible to assist you in a meaningful way. I have left some instruction in the other thread. Try that out.