Bahmni Connect Sync Issue


I have been trying to setup bahmni connect by following the official bahmni Wiki Page with bahmni version 0.90 and Chrome extension version 0.88. I’ve followed each and every steps given in that page, But the bahmni connect sync is not happening. I’m getting an error in my chrome extension like The requested information does not exist.

I’ve sorted two main issues with my bahmni connect :

  1. When i execute the command bahmni -i local create-connect-artifacts for creating connect artifacts it shows an error like :

fatal: [localhost]: FAILED! => {“changed”: true, “msg”: “non-zero return code”, “rc”: 1, “stderr”:"",“stdout”:“Invalid Username/Password\n”, “stdout_lines”: [“Invalid Username/Password”]}

  1. When i’m trying to use bahmni connect it shows the error “The requested information does not exist”.

I am looking for a resolution for this issue. Hoping someone in the forum who would have experienced the same issue be able to help me out. Thanks in advance!

Hi @rajeebrasak,

  • For Step 1, you have to use OpenMRS admin user credential (wait for OpenMRS startup).
  • For Step 2, you should finish the Step 1 first then reinstall Bahmni Connect on device and retry to sync

thanks for reply @sumanmaity112. But i’ve tried of given the openMRS admin credentials(superman/Admin123), and still it shows same error.

Do you able to login from browser with same credential?

Can you try to login from browser first and check if it’s working or not?

Yes I’m able to login to openMRS from browser with the same credentials.

@rajeebrasak Can you try with below credentials once


@binduak Tried, but this credentials also not working.

Same Problem Encountered… Any solutions? I need also to install the bahmni-connect server and apps. Thank you.

I got it working…

  1. Stop the OpenMRS services (sudo service openmrs stop)
  2. Start then OpenMRS services (sudo service openmrs start)
  3. Install again bahmni connect (yum install bahmni-offline)
  4. Run the command (bahmni -i local create-connect-artifacts)
  5. Success, if not → try to make the runtime properites module to true (module.allow_web_admin=true) / filename=/opt/openmrs/etc/ then, try again from step 1.

Thank you.

1 Like