Announcing Bahmni 0.92 Release Candidate

I have same logs but now I can browse bahmni. Can you recheck after restarting ?

Odoo is unable to start after server unexpected power outage, i tried letting Odoo start at boot with the command chkconfig odoo on but this does not work when server unexpectedly shutdown- odoo won’t start unless started manually. Any solution to this?

Hello @angshuonline, I have been trying for over 2 weeks now to install Bahmni 0.92 on Centos7 but it’s failing. Initially I had a custom inventory file because I am installing all DBs on a separate server. When I ran command bahmni -i inventory install, nothing gets installed except MySQL on the remote server.

I then tried installing everything on the localhost with bahmni -i local install, but I got this error message

TASK [mysql : Update mysql root password] *************************************************************************************************************************
task path: /opt/bahmni-installer/bahmni-playbooks/roles/mysql/tasks/main.yml:60
fatal: [localhost]: FAILED! => {"changed": true, "cmd": "mysql -e \"UPDATE mysql.user SET authentication_string=PASSWORD('**********') WHERE User='root'; FLUSH PRIVILEGES;\" -u root -i -p'**********'", "delta": "0:00:00.009389", "end": "2019-10-15 11:01:54.306947", "msg": "non-zero return code", "rc": 1, "start": "2019-10-15 11:01:54.297558", "stderr": "mysql: [Warning] Using a password on the command line interface can be insecure.\nERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)", "stderr_lines": ["mysql: [Warning] Using a password on the command line interface can be insecure.", "ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)"], "stdout": "", "stdout_lines": []}
        to retry, use: --limit @/opt/bahmni-installer/bahmni-playbooks/all.retry

PLAY RECAP ********************************************************************************************************************************************************
localhost                  : ok=65   changed=22   unreachable=0    failed=1

Hi @tapologo I have just replied on the other thread. It seems you have some invalid characters in your inventory file! (so suggests the log)

Couple of things

  1. Try running the installer command with -vv option. That will provide you with more information (more number of v, means more debug info)

bahmni -i local install -vvvv

  1. also check the install logs, which is available at the control machine (where you triggered installation from).

/bahmni_temp/logs/bahmni_deploy.log

Also, regarding inventory file, you can find more explanation about inventory files and ansible specific information here

Thanks, I have responded here

Thanks @angshuonline, the issue with invalid characters was resolved.

Is there a solution for this one

I followed this workaround but it did not work

I get this error message when I run systemctl status openmrs.service

New main PID 1463 does not belong to service, and PID file is not owned by root.

And this when I run systemctl start openmrs

Job for openmrs.service failed because a configured resource limit was exceeded. See "systemctl status openmrs.service" and "journalctl -xe" for details.

Hello @stephencoduor, were you able to resolve the odoo problem? May you please share how you resolved it because I am facing the same issue

Hello @angshuonline, any idea why this is happening?

service odoo status
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
mkdir: cannot create directory ‘odoo’: File exists 

I also noticed that openerp database was not created

postgres=# \l
                                   List of databases
    Name     |  Owner   | Encoding |   Collate   |    Ctype    |   Access privileges
-------------+----------+----------+-------------+-------------+-----------------------
 bahmni_pacs | postgres | UTF8     | en_US.UTF-8 | en_US.UTF-8 | =Tc/postgres         +
             |          |          |             |             | postgres=CTc/postgres+
             |          |          |             |             | pacs=CTc/postgres
 pacsdb      | postgres | UTF8     | en_US.UTF-8 | en_US.UTF-8 |
 postgres    | postgres | UTF8     | en_US.UTF-8 | en_US.UTF-8 |
 template0   | postgres | UTF8     | en_US.UTF-8 | en_US.UTF-8 | =c/postgres          +
             |          |          |             |             | postgres=CTc/postgres
 template1   | postgres | UTF8     | en_US.UTF-8 | en_US.UTF-8 | =c/postgres          +
             |          |          |             |             | postgres=CTc/postgres

This problem (resource limit exceeded issue) still persists in our new deployments , actually this is the blocker issue for us to go for production implementations.

@angshuonline can we prioritize this issue ?

cc: @utsavdeshar | @deepakneupane | @sanjayap

1 Like

Can you tell me what version of Centos7 are you using?

cat /etc/centos-release

I started investigating that, and came across similar error on CentOS7.7. I am wondering if its relevant to a reported issue https://access.redhat.com/solutions/4397951

Can you try with CentOS 7.6 or 7.5?

Don’t use “systemctl status openmrs”. Depending on your Systemd version, I think you will come across this problem. https://access.redhat.com/solutions/4397951

use

service openmrs start

Local Setup - Master - Slave

Installer Version - 0.92-142

I still see these errors in ODOO.

Though ODOO works fine on master but patients do not sync from Bahmni to ODOO. bahmni-erp-connect is running fine and markers as well as failed_events are empty on both openmrs and odoo databases.

On slave, ODOO is showing this jquery error which is surprising as this being a master - slave setup and slave db should have been exact copy of master, right?

Hi laxman,

I replied on another thread regarding the same issue - you could find it here.

this was because this entire section was missing in the file that got installed. This needs further investigation on our side.

I also noticed that the installation puts openelis parameters only if bahmni-lab is to be installed whereas none of the attributes are optional in this OpenERPAtomFeedProperties.java class.

So we may have to test installing without bahmni-lab if bahmni-erp-connect runs normally or does the file erp-atomfeed.properties need manual modifications?

Bahmni ERP Connect should work irrespective of whether LAB is installed or not. the Feed URLs of the lab should be blank, which makes the feed consumer ignore it.

Hi @angshuonline , when I change odoo password from the default admin username and password, bahmni does not send orders to odoo. When I revert back the to the default everything works again

Is anyone experiencing this? Must the password remain as the default

Need to update the changed username and password to file path /opt/bahmni-erp-connect/bahmni-erp-connect/WEB-INF/classes/erp-atomfeed.properties on odoo section: openerp.port=8069 openerp.host=localhost openerp.database=odoo openerp.user=admin(default) openerp.password=admin(default) for sync from openmrs to odoo.

Thats because “admin” is the user that was used for integration.

To do this, you need to

  1. shut down the “bahmni-erp-connect” service
  2. modify the file “/opt/bahmni-erp-connect/bahmni-erp-connect/WEB-INF/classes/erp-atomfeed.properties” and modify the properties - “openerp.user” and “openerp.password”.
  • there are other ways of modifying such runtime properties. Check the WIKI documentation here
  1. restart the service.

When I try to sync Bahmni with Odoo I get this error

This happens when I click the Bahmni Atom Feed app in Odoo. Also when I try to access AtomFeed Console from Bahmni home i get below error

Not Found

The requested URL /atomfeed-console was not found on this server.

Have you tried restarting the services

systemctl restart bahmni-erp-connect

systemctl restart odoo

I have tried it already, I still get the same error